WordPress Vulnerability In Shortcodes Greatest Impacts 700,000 Sites

The United States govt National Vulnerability Database (NVD) posted an advisory about Shortcodes Greatest WordPress plugin, warning that it was found to consist of a Cross Web-site Request Forgery vulnerability.

Domain & Hosting bundle deals!

Shortcodes Top is a really well known WordPress plugin that has more than 700,000 energetic installations.

The vulnerability influences plugin versions that are older than the present edition 5.12.2.

Cross-Web-site Request Forgery Vulnerability

Cross-Website Request Forgery, normally referred to as CSRF, is a sort of vulnerability that can in the worst scenarios can guide to full web page takeover.

These sorts of vulnerabilities are frequently prompted by targeting a flaw in computer software that can set off a alter, which can then lead to unintended repercussions.

A productive attack usually is dependent on a consumer, for instance with administrative privileges, clicking on a website link and unintentionally revealing information and facts like a session cookie which can then be used to impersonate that person.

This type of vulnerability depends on social engineering, which is manipulating an end consumer to entire an action which then will take benefit of the plugin vulnerability.

According to the Open up World wide web Software Protection Venture (OWASP):

“CSRF is an assault that tricks the sufferer into publishing a destructive ask for.

It inherits the identity and privileges of the victim to conduct an undesired functionality on the victim’s behalf…

For most websites, browser requests mechanically contain any credentials linked with the web page, these kinds of as the user’s session cookie, IP deal with, Windows domain credentials, and so forth.

For that reason, if the consumer is at this time authenticated to the site, the internet site will have no way to distinguish in between the cast request sent by the sufferer and a reputable ask for despatched by the sufferer.”

Nationwide Vulnerability Databases (NVD)

The Countrywide Vulnerability Databases published just a handful of facts about the vulnerability. There is at present no full breakdown of the vulnerability by itself.

The NVD advisory posted the adhering to:

“Cross-Internet site Ask for Forgery (CSRF) vulnerability in Shortcodes Supreme plugin <= 5.12.0 at WordPress leading to plugin preset settings change.”

The official Shortcodes Ultimate GitHub changelog was similarly vague, describing the update to fix the vulnerability:

“### 5.12.1

**Security release**

This update fixes a security vulnerability in the shortcode generator. Thanks to Dave John for discovering it.”

Meanwhile the WordPress plugin repository changelog explains:

“Fixed issue with Shortcode Generator Presets, introduced in the previous update”

The above changelog appears to misspell the security researcher’s name, which is correctly spelled Dave Jong, CTO of Patchstack, the person who is credited with discovering and reporting the vulnerability.

Recommended Course of Action

WordPress publishers who currently use Shortcodes Plugin should consider updating to the very latest version, which at the time of writing is currently version 5.12.2.


Read the National Vulnerability Database Advisory

CVE-2022-38086 Detail

Read the Patchstack Announcement

WordPress Shortcodes Ultimate plugin <= 5.12.0 – Cross-Site Request Forgery (CSRF) vulnerability

Featured Image by Shutterstock/Cookie Studio

You May Also Like